Membuat Virtual Host di Ubuntu tanpa DNS Server

Read the rest of this entry »

Sebelumnya telah dibahas mengenai cara Membuat Virtualhost di Ubuntu, namun artikel kali ini sedikit berbeda karena tidak menggunakan DNS Server dan hanya berlaku untuk jaringan kecil, artikel ini sama dengan artikel sebelumnya yaitu Membuat Virtual Host Pada Web Server Apache namun yang membedakan adalah sistem operasi, pada artikel Membuat Virtual Host Pada Web Server Apache sistem operasi menggunakan Windows XPdan PAket Server XAMPP sedangkan pada artikel kali ini menggunakan Sistem OPerasi Linux Ubuntu 10.04 tanpa paket server apapun, tetapi menginstal satu-persatu server secara terpisah (baca artikel : Instal MySQL, PHP, Apache di linux Ubuntu). Sekiranya cukup pengantar tentang artikel ini mari kita bahas step by step nya :

1. Login sebagai root karena untuk mengakses web server membutuhkan otentifikasi root

$sudo -s

2. Masuk ke direktori /etc/apache2/sites-available

#cd /etc/apache2/sites-available

3. Copy file default menjadi nama virualhost misal http://www.webku.com

#cp default http://www.webku.com

4. Edit file http://www.webku.com dengan editor kesayangan anda

#pico ww.webku.com

5. Ubah dan tambahkan beberapa baris dibawah ini :

DocumenRoot     /data2/SERVER_FILE/htdocs/webku
ServerName     webku.com
ServerAlias http://www.webku.com
<Directory />
Options FollowSymLinks
AllowOverride None
</Directory>
<Directory /data2/SERVER_FILE/htdocs/webku>
Options Indexes FollowSymLinks MultiViews
AllowOverride None
Order allow,deny
allow from all
</Directory>

6. Aktifkan virtual host yang telah dibuat dengan perintah

#a2ensite http://www.webku.com

7. Edit File host yang berada di direktori /etc

#pico /etc/hosts

8. Tambahkan baris dibawah ini kemudian simpan

127.0.0.1 http://www.webku.com

9. Reload setting apache2 dengan perintah

#/etc/init.d/apache2 reload

10. Cek di browser dengan memanggil http://www.webku.com jika halaman yang dimaksud tampil berarti pekerjaan anda telah berhasil membuat virtual host

Copas :http://oz.orgfree.com/2012/02/membuat-virtual-host-di-ubuntu-tanpa-dns-server/

Cara Mengganti Repository Pada Ubuntu 10.10 (Maverick) 

Saya kali ini ingin menjelaskan bagaimana cara dan langkah-langkah dalam mengganti repository pada Ubuntu 10.10 dengan menggunakan repository yang disediakan oleh Kambing UI. Untuk mengganti repository pada Ubuntu, anda harus mengganti daftar repository yang terdapat pada file ‘sources.list’ (/etc/apt/sources.list). Ada baiknya anda mem-backup file ‘sources.list’ anda terlebih dahulu sebelum mulai mengeditnya. Berikut langkah-langkah untuk mengganti repository anda:

1. Buka terminal pada Ubuntu anda (Ctrl+Alt+T).
2. Ketikkan “sudo gedit /etc/apt/sources.list” lalu masukkan password anda.

3. Setelah file ‘sources.list’ terbuka. Hapus semua isi file tersebut dan ganti dengan server Kambing UI:

deb http://kambing.ui.ac.id/ubuntu maverick main restricted universe multiverse
deb http://kambing.ui.ac.id/ubuntu maverick-updates main restricted universe multiverse
deb http://kambing.ui.ac.id/ubuntu maverick-security main restricted universe multiverse
deb http://kambing.ui.ac.id/ubuntu maverick-backports main restricted universe multiverse
deb http://kambing.ui.ac.id/ubuntu maverick-proposed main restricted universe multiverse

4. Setelah itu, save file ‘sources.list’ tersebut dan buka kembali terminal anda.
5. Ketikkan “sudo apt-get update” pada terminal anda.

Cara Menginstall Nero Di Ubuntu

Untuk membakar CD / DVD biasanya para pengguna Ubuntu memakai Software khusus Burning seperti  “Brasero Disc Burner”, tapi bagi pengguna Ubuntu yang masih awam (seperti saya, hehehehe) tidak tahu akan software burning untuk Ubuntu, apalagi untuk pengguna yang beralih dari Windows XP dan sejenisnya . . . :D

Di sini para pengguna Ubuntu pasti memilih mengunakan “Wine” , software khusus Ubuntu untuk menginstall file “exe”….

Tapi sebenarnya masih ada pilihan lainnya, saya sendiri baru menemukannya kemarin… (ehemb, masih pemula) yaitu NERO untuk Ubuntu, yappp …. !!! selamat menyimak !!! ^.^

LANGKAH MENGINSTALL NERO FOR UBUNTU :

Yang Dibutuhkan : – nerolinux-3.5.3.1-x86.deb (karena versi terbaru masih trial, hehehehhehe)

– keymaker (bisa di download disini)

Keymaker Nero 3.5.3.1 : “http://www.ziddu.com/download/5685895/keymaker.rar.html

Nero 3.5.3.1 trial : “http://nero-linux-3-5-3-1-x86-all-distros-5040564.cooga.net/

Langkah – Langkah :

1. Taruh semua file ke dalam folder /opt

2. Buka Terminal 

3. Masuk ke dalam direktori “/opt”

#cd /opt

4. Install file “nerolinux-3.5.3.1-x86.deb” dengan perintah.

#sudo dpkg -i nerolinux-3.5.3.1-x86.deb

Tekan ‘Enter’, kemudian tunggu sampai penginstallan selesai.

5. Setelah itu buka file nero :

Applications – Sound & Video – Nero Linux

akan muncul tampilan berikut :

6. Tandai kalimat “I accept the terms of the licence conditions” Tekan ‘Spasi’ atau ‘Klik Kanan’.

Tekan ‘Next’.

Setelah itu akan muncul tampilan di bawah ini.

Hemb disini muncul pengisian ‘Serial Number’. Untuk versi full dibutuhkan Keymaker… kalau sudah mendownload keymakernya kembali ke ‘terminal’

Sebelum file terekstrak, pastikan Unrar telah terinstall di Ubuntu anda !! dengan perintah “sudo apt-get install unrar”

7. Ekstrak file “keymaker.rar” dengan perintah berikut :

#unrar  x keymaker.rar

8. Install file “keymaker” dengan perintah :

#chmod +x keymaker

#./keymaker

Setelah itu Catat “Serial Number” yang terdapat pada file ‘keymaker’

Taruh Serial Number ke dalam kotak Serial Number yang berada pada tampilan berikut:

Tekan “OK”

Kalau anda berhasil akan muncul tampilan di bawah ini :

Nero siap untuk digunakan ….

Silahkan Mencoba… !!! :-D

 

copas : http://reynaldidwi.wordpress.com/2010/10/26/cara-menginstall-nero-di-ubuntu/

NICE Mikrotik

Mulai Mikrotik RouterOS versi 2.9, dikenal dengan fitur yang disebut IP Address List. Fitur ini adalah pengelompokan IP Address tertentu dan setiap IP Address tersebut bisa kita namai. Kelompok ini bisa digunakan sebagai parameter dalam mangle, firewall filter, nat, ataupun queue.

Mikrotik Indonesia telah menyediakan daftar IP Address yang diadvertise di OpenIXP dan IIX, yang bisa didownload dengan bebas di URL:http://www.mikrotik.co.id/getfile.php?nf=nice.rsc

File nice.rsc ini dibuat secara otomatis di server Mikrotik Indonesia setiap jam, dan merupakan data yang telah dioptimalkan untuk menghilangkan duplikasi entri dan tumpang tindih subnet. Saat ini jumlah baris pada script tersebut berkisar 7000 baris.

Contoh isi file nice.rsc :

# Script created by: Valens Riyadi @ www.mikrotik.co.id
# Generated at 26 April 2007 05:30:02 WIB ... 431 lines
/ip firewall address-list
add list=nice address="1.2.3.4"
rem [find list=nice]
add list=nice address="125.162.0.0/16"
add list=nice address="125.163.0.0/16"
add list=nice address="152.118.0.0/16"
add list=nice address="125.160.0.0/16"
add list=nice address="125.161.0.0/16"
add list=nice address="125.164.0.0/16"
.
.
dst...

Proses pengambilan file nice.rsc bisa dilakukan langsung dari terminal di RouterOS dengan perintah:

/tool fetch address=ixp.mikrotik.co.id src-path=/download/nice.rsc;

Kemudian, import-lah file tersebut.

[admin@MikroTik] > import nice.rsc

Opening script file nice.rsc
Script file loaded and executed successfully

Pastikan bahwa proses import telah berlangsung dengan sukses, dengan mengecek Address-List pada Menu IP – Firewall
address list nice

Proses upload ini dapat juga dilakukan secara otomatis jika Anda memiliki pengetahuan scripting. Misalnya Anda membuat shell script pada Linux untuk melakukan download secara otomatis dan mengupload file secara otomatis setiap pk 06.00 pagi. Kemudian Anda tinggal membuat scheduler pada router untuk melakukan import file.

Jika Anda menggunakan RouterOS versi 3.x, proses update juga dapat dilakukan secara otomatis.

Perintah yang perlu dibuat adalah :

/system sched add comment=”update-nice” disabled=no interval=1d name=”update-nice-rsc” on-event=”:if ([:len [/file find name=nice.rsc]] > 0) do={/file remove nice.rsc }; /tool fetch address=ixp.mikrotik.co.id src-path=/download/nice.rsc mode=http;/import nice.rsc” start-date=jan/01/1970 start-time=06:00:00

Hati-hati! : Setelah copy paste, pastikan hasil copy paste sama persis. Proses copy paste kadang-kadang menghilangkan beberapa karakter tertentu.

Seber : http://www.mikrotik.co.id

Seting Waktu Secara Otomatis Pada Mikrotik

Bingung bagaimana men-setting jam pada router board mikrotik. Sebenernya mudah saja. Bila tau triknya. Nah yang gak tau dengan membaca blog ini bisa jadi tau dah. Ok ga berpanjang lebar caranya adalah begini.

  1. Buka mikrotik routerboarad anda via winbox
  2. Klik System -> pilih NTP Client
  3. Checklist Unicast dan pada primary NTP Server isikan : 203.160.128.178
  4. Secondary NTP server : isikan ip ntp lainnya yang anda suka silahkan cari di pool.ntp.org
  5. Laluk klik tombol Apply -> OK
Cara ini lah yang di gunakan untuk mensyncronisasi jam routerboard dengan jam international. Karena router board mikrotik tidak memilik bateray cmos layaknya komputer sehingga tidak menyimpan time secara terus menerus tanpa di aliri listrik. Nah dengan mensetting NTP server otomatis mikrotik akan menyesuaikan time /jamnya dengan jam international. Lihat gambar di bawah ini sebagai contohnya.
Nah itu dia sekelumit kisah, setting time router board mikrotik agar sama dengan waktu realnya. Semoga bermanfaat.

Cara Compress File dan Folder di Linux

1. Compress File.

Seperti biasa masuk ke SSH, biasa menggunakan PUTTY, ketikkan perintah :

# gzip namafile > namafile1.gz

dimana namafile=nama file yg akan dicompress, dan namafile1.gz adalah nama file hasil compress tersebut.
2. Compress Folder.

Ketikkan perintah :

tar -cvf – directory_name | gzip -c > newfilename.tar.gz

Proses kompress tersebut akan berhasil jika linux anda sudah terinstall packet GZIP.

Copas :http://duniapajak.com/hobby/2011/cara-compress-file-dan-folder-di-linux

INSTALL MINITUBE UBUNTU

Minitube adalah YouTube client yang berkemampuan memainkan video di YouTube tanpa harus membuka web browser dan Flash player. Kita cukup membuka Minitube, masukkan keyword untuk mencari video, pilih video yang akan diputar, dan video siap untuk dinikmati. Minitube menggunakan interface Qt >= 4.5 dan engine multimedia “Phonon”.

Beberapa fitur dari Minitube:

  • Mampu memainkan video kualitas tinggi (1080 piksel)
  • Mampu meng-copy link dari YouTube ke clipboard
  • Ukuran jendela aplikasi menyesuaikan ukuran video
  • Mendukung beberapa bahasa yaitu English, Romanian, Greek, Dutch, Arabic, Portugese, Finnish, Bulgarian.

Untuk info lebih lanjut klik di sini.

Untuk menginstal Minitube di Ubuntu bisa dilakukan dengan cara sebagai berikut:

Buka terminal dan ketik:

  1. sudo add-apt-repository ppa:neversfelde/ppa
  2. sudo apt-get update
  3. sudo apt-get install minitube
Seperti dikatakan di atas, Minitube menggunakan engine Phonon untuk memainkan video. Namun, kebanyakan pengguna Ubuntu lebih suka menggunakan engine GStreamer untuk multimedia. Hal tersebut dapat diatasi dengan cara:
Buka terminal dan ketik:
  1. sudo apt-get install phonon-backend-gstreamer gstreamer0.10-ffmpeg gstreamer0.10-plugins-bad
  2. sudo apt-get remove phonon-backend-xine

sumber / copas : http://www.tahutek.net